Check Engine Light On -s : | platizazvonok.ru
LinkBack Thread Tools
post #1 of 9 (permalink) Old 05-19-2005, 07:48 AM Thread Starter
Junior Member

Join Date: Sep 2004
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
dingdong
(Thread Starter)
hi

has anyone encountered check engine light turning on with their matrix before.

today the check engine light on my car light up again. this is the 4th time it happened since i got the car in oct 2003. There is no loss of power or drive. just feels like the engine is slightly rougher, but not by a lot, could be my imagination!

reason i got from service centre in the past 3 times:
1) ECU connector lose
2) O2 sensor faulty (apparantly there is 2 O2 sensor in matrix, both have been changed before)

just curious if it is happening only to me or has anyone encountered too.

i am using SPC 92 petrol, but i doubt that is the cause as the manual states that any grade above 91 is ok (i think).

just have to send in and see what they say tomorrow.

For those living in Singapore, enjoy the long weekend.
dingdong is offline
Sponsored Links
Advertisement

post #2 of 9 (permalink) Old 04-16-2007, 05:02 AM
Senior Member

Join Date: Mar 2005
location: Cairo, Egypt
Drives Hyundai ix20 1.6 Automatic, Trim : EQ
Posts: 142
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Ahmad_Abdallah
Send a message via MSN to Ahmad_Abdallah Send a message via Yahoo to Ahmad_Abdallah
could be bad fuel quality that affects your O2 sensor ... could be your control unit ( ECU ) I had the same problem and I changed the O2 sensor and the MAP sensor two times and finally they discovered that the main reason was the ECU and they replaced it under warranty ...
by the way ... do you have your check light going ON when moving the key to ON position before starting the car then OFF again ? or should it only be ON when there is a problem ?!!
Ahmad_Abdallah is offline
post #3 of 9 (permalink) Old 12-09-2012, 08:32 PM
Junior Member

Join Date: Jan 2011
location: Indonesia, Jatim
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
lkhakim
i have the same problem. so i buy ODB from this site

i can control check engine light turning off from android phone
and i can see all engine matrix sensor included gasoline consumption MPG/KPL

its wonderful stuf.

i still have 2 more. u can call/sms me in +3
or email me

thanks
lkhakim is offline

post #4 of 9 (permalink) Old 12-12-2012, 01:21 PM
Junior Member

Join Date: Oct 2010
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
pitrat
Engine managment light

I have had the eml come on and then gooff 2 or 3 times per week for the last 4 years. It has been to hyudai dealers 3 times to be checked out but they could not find anythingh wrong, and at £75 a time you get fed up worrying about it.
pitrat is offline
post #5 of 9 (permalink) Old 02-15-2014, 04:33 PM
Junior Member

Join Date: Jun 2009
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
ojayspbody
2003 Matrix 1.6 Gsi Auto.
Very similar symptoms.
Start engine from cold and 2 minutes later the EML starts flashing, this happens for about another 2 minutes then goes out.
Never happens when the engine is hot.
Used my diagnostic gizmo and came up with misfire no2 cylinder and code: P1259 #11.
Have changed the plugs/checked the leads and all appear OK.
Light still does the same.
Haven't noticed any loss of power, only slightly higher fuel consumption than normal.
Ideas please!
Thank You for reading
ojayspbody is offline
post #6 of 9 (permalink) Old 02-24-2014, 01:23 PM
Junior Member

Join Date: Jun 2009
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
ojayspbody
Unfortunately this problem has continued.
From cold in the morning it starts just fine, but after approx. half a mile the engine management light starts flashing on/off. It now misfires when this happens, but after about another half mile the light goes out and the misfire disappears.
This only happens from a cold engine.
I have changed plugs/leads and made no difference.
Codes now coming up indicate Generic PO722 $18 'Output Speed Sensor No Circuit' & Generic PO302 $11 Cylinder 2 Misfire Detected.
Can someone inform me where the 'Output Speed Sensor' is situated on the transmission box please.
Thanks
Gregg

Last edited by ojayspbody; 02-24-2014 at 01:28 PM.
ojayspbody is offline
post #7 of 9 (permalink) Old 01-29-2015, 04:29 PM
Junior Member

Join Date: Jun 2009
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
ojayspbody
Replaced the input & output speed sensors and no further problem so far.
ojayspbody is offline
post #8 of 9 (permalink) Old 01-29-2015, 04:31 PM
Junior Member

Join Date: Jun 2009
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
ojayspbody
Replaced the input & output speed control sensors and had no problem since.
ojayspbody is offline
post #9 of 9 (permalink) Old 01-29-2015, 04:32 PM
Junior Member

Join Date: Jun 2009
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
ojayspbody
See below.
ojayspbody is offline
Sponsored Links
Advertisement

Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the platizazvonok.rus : platizazvonok.ru forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to


Related pages


api sm ilsac gf 4cobalt ss body kitskyb lowering springswhistle tip mufflertransmission flush at jiffy lubevvme coupon code2007 kia spectra oil typemitsubishi firing order2009 subaru legacy roof rackpo174 engine codehydraulic valve lifter noiseillest car emblemkia sorento fuel pumphow much for brake pads and rotors replacement370z vs genesis coupep1120 codewayne hyundai nj2003 santa fe recallsput auxiliary input your car2014 elantra gt 0 60how much is a crankshaft pulley2005 hyundai tiburon engineexhaust condensation smokehow to remove tar from your carhyundai blue link customer service numberford focus rear brake shoeshow to fit drl lightsmanual transaxle fluidtiburon 2006replace outer cv boothow to burnout automatichoagland hyundairsx type s starterignition key won t turnhyundai replacement key fobhyundai accent tail lightfront brake caliper leaking fluidafter market cruise control2003 ford explorer transmission fluid capacityroadside assistance hyundai canadaengine code p0102average transmission flush costengine jerks while drivinghyundai quebechyundai amica124r car batteryhoosier air tankcrv or santa fesan luis obispo hyundaioem mazda wheels5w20 or 5w302003 hyundai elantra batterycastrol synthetic atftucson diesel priceshyundai car brandsouter cv boot splitmonroney window stickerairbag light on hyundaitire pressure sensor blinkingmost expensive hid kithow to put in freontire pressure hyundai elantrakia sorento check engine light5w40 vs 0w40hyundai mpg infohyundai coupe window motorgdi turboinstall heated seatsgoof off on plasticcross beam floor jack adapterhow to reset rear brake caliper pistonghetto chrysler 3002013 hyundai accent oil capacitywhy is my car ac not blowing cold airmy heater in my car blows cold airmonroney label lookuppl14459 oil filterosram h7 rallyelowes key duplication